Versão 2 do plugin do Technorati Rank para WordPress lançado!

Logo após o primeiro Technorati Rank Plugin, redesenhei o conteúdo de saída para torná-lo CSS dirigido (abaixo está uma captura de tela, você pode interagir com a barra lateral do meu site):

Plugin Technorati Rank WordPress versão 2

Este foi um pouco mais desafiador de produzir, mas a saída é muito mais agradável. Primeiro, usei o que aprendi sobre Bittbox para fazer cada um dos botões de saída da imagem no Illustrator.

A próxima etapa foi utilizar estilos para realmente construir alguém de um mapa de imagem exceto que há realmente nenhum mapa! É muito legal, na verdade. Você pode definir o plano de fundo geral do div e, em seguida, criar cada um dos 'pontos de acesso' utilizando posicionamento absoluto e CSS. Visualize o CSS de saída.

Eu também adicionei um link para o novo Technorati WTF página e o endereço RSS do site. Espero que você goste! Acho que é uma grande melhoria em relação à primeira versão! Há uma i link no canto inferior direito que também promove o plug-in.

Plugin Technorati Rank WordPress atual versão 2.0.4

23 Comentários

  1. 1
  2. 3

    Tentei instalar o mais novo e melhor seguindo suas instruções ao pé da letra 🙂

    mas eu tenho o seguinte erro

    Erro fatal: não é possível instanciar uma classe inexistente: simplexmlelement in /home/winex4/public_html/wp-content/plugins/technorati-rank/technorati-rank.php na linha 64

    alguma sugestão?

    • 4
      • 5

        isso vai me ensinar a verificar primeiro .. aparentemente o Lunarpages está rodando 4.4.4 de PHP

        Acho que terei que verificar a outra versão ou aguentar firme e ver se eles atualizam para 5.0

        • 6

          Espero que sim! Mas também espero que seu host seja atualizado. O PHP5 realmente traz melhorias de desempenho muito melhores, assim como algumas ferramentas melhores para consumir APIs. Eu utilizo o Jumpline, você verá um link na minha lista de patrocinadores na minha página inicial. Também acredito que a Dotster tem uma boa hospedagem VDS com o que há de melhor e mais recente.

      • 7

        Doug,
        Estou tendo o mesmo problema
        Liguei para meu host e eles disseram que meu servidor tem PHP 4 e PHP 5, mas se eu quiser executar um arquivo usando PHP 5, o script precisa ter extensão de arquivo .php5.

        Então… eu mudei as extensões do arquivo, e ele desaparece dos plugins do wordpress.

        Alguma ideia?

  3. 10

    Plugin incrível, estilo excelente! Obrigado Doug, e ótimo trabalho. Eu nem sabia sobre o primeiro, mas isso vai para minha barra lateral imediatamente.

    É REALMENTE gratificante ver que minhas dicas do Illustrator ajudaram você a fazer seus botões !!!!!

    obrigado novamente,

    ~ BittBox

    • 11

      Obrigado, BittBox! Acho que tenho um bom olho para o estilo, mas nunca consigo acertar na maioria das vezes. Ser capaz de realmente baixar suas amostras e dissecá-las é o que faz a diferença. Sou capaz de executar essas ideias agora. 🙂

      A seguir, estou brincando com algumas ideias sobre o cabeçalho e o histórico do meu blog.

  4. 12

    Bem, Doug, parece que o plugin da versão 2 me odeia. Recebo mensagens de erro:

    Warning: fopen(/technorati-rank.html) [function.fopen]: failed to open stream: Permission denied in /..../wp-content/plugins/technorati-rank/technorati-rank.php on line 121
    Warning: fwrite(): supplied argument is not a valid stream resource in /..../wp-content/plugins/technorati-rank/technorati-rank.php on line 122
    Warning: fclose(): supplied argument is not a valid stream resource in /..../wp-content/plugins/technorati-rank/technorati-rank.php on line 123

    Apesar das mensagens de erro, ele também mostra minha classificação Technorati (~ 26.5k: D). Não tenho conhecimento suficiente sobre PHP para saber por que ele está chorando por causa daquele arquivo.
    Curiosamente, em nosso servidor, usamos SuPHP, então tudo funciona como nós (então os requisitos de chmod não exigem mais arquivos graváveis ​​por todo o mundo e os scripts de php não serão executados se o chmod for muito alto, por exemplo).

    Todo o php para este subdomínio é executado como php5.

    Alguma idéia?

    • 13

      Você tem um diretório wp-content / cache Xial? Achei que seria uma boa ideia utilizar o mesmo diretório de cache do WP-Cache. Olhando para trás, talvez não tenha sido uma boa ideia! Essa linha é definitivamente para gravar no arquivo de cache.

      • 14

        Certamente que sim, Doug. Estou executando o WP-Cache há um bom tempo. 🙂

        Eu também estava um pouco curioso para saber por que ele reclamaria sobre isso, já que tenho o diretório necessário, mas acho que é outra coisa.

      • 15

        Informação interessante para adicionar:

        $ pwd
        /..../wp-content/cache
        $ ls -l tech*
        -rw-r--r-- 1 meeeeeeee meeeeeeee 1.1K Mar 12 11:47 technorati-rank.html

        Ele ainda retorna os erros.

    • 16

      Só quero gritar com o mesmo erro. O site executa php5 e o botão é exibido.
      Tentei comentar as linhas 121-123 e o plug funciona bem. Posso colocá-lo no ar ou a falta dessas linhas causará problemas a longo prazo?

  5. 17

    Estou recebendo os mesmos erros acima, também pensei que fosse meu diretório de cache, mas tenho um e também verifiquei se os direitos de gravação estavam corretos.
    Na barra lateral irá mostrar o plugin (com classificação), mas com os erros acima dele.

    • 18

      Oi Richard,

      Você pode verificar se possui a versão 5+ do PHP e se o CURL está ativado? Você pode fazer isso criando uma página em seu site com <?php phpinfo(); ?> em uma página. Em seguida, abra essa página. O topo da página terá sua versão do PHP e você pode fazer uma pesquisa por CURL para garantir que está ativado.

      Obrigado!
      Doug

      • 19

        Bem, Doug, verifiquei duas vezes minha versão do PHP.
        Estou executando o PHP5 e o cURL está compilado (uma das minhas três solicitações habituais ao meu host, para que as coisas sejam compiladas em PHP).

        Todo o resto funciona bem, mas não tenho certeza de por que este plugin está sufocando, a menos que seja a versão do cURL compilado para o PHP (estamos em 7.15.4 e o mais recente parece ser 7.16.1). No entanto, não quero incomodar meu host para compilar o php5 novamente apenas para isso, se eu puder evitar. <: 3

        • 20

          Vou dar uma olhada mais detalhada neste fim de semana. Está rodando sem problemas em alguns sites - então é uma de 3 coisas: 1. Cache, 2. cURL ou 3. Versão PHP.

          Posso utilizar a funcionalidade do PHP 4 mais antiga para extrair e analisar o XML, mas isso pode desacelerar um pouco - vou testar neste fim de semana. Aprecio todas as indicações. "Houston, nós temos um problema!".

  6. 21

    Apenas uma nota: a Technorati lançou um Autoridade Plugin

    Além disso - para todos aqueles que estão tendo problemas com este plugin, eu realmente encorajo você a mudar para um novo host :). Eu tenho um especial de 12 meses grátis com meu anfitrião na parte inferior do meu Sobre Nós Disputas de Comerciais.

  7. 22
  8. 23

    Recebi algumas solicitações de erros ao gravar ou ler o arquivo de cache. Na verdade, identifiquei um problema em que estava empurrando e puxando o arquivo de cache para o diretório raiz. Modifiquei a versão 2.0.4 para que ela grave em um subdiretório de cache dentro do diretório do plug-in.

    Por favor, deixe-me saber como funciona! (Ainda precisa de SimpleXML e cURL!)

O que você acha?

Este site usa o Akismet para reduzir o spam. Saiba como seus dados de comentário são processados.